创建自定义模块后,setup:upgrade命令后报错

已解决992 浏览故障排除新手

创建自定义模块后,setup:upgrade命令后报错

执行命令报错

alian@DESKTOP-KL4FE27:~/Sites/magento$ bin/magento setup:upgrade
Warning: DOMXPath::query(): Invalid expression in /var/www/html/vendor/magento/framework/Config/Dom.php on line 337
alian@DESKTOP-KL4FE27:~/Sites/magento$ bin/root chmod -R 777 ./var
alian@DESKTOP-KL4FE27:~/Sites/magento$ bin/magento setup:upgrade
Warning: DOMXPath::query(): Invalid expression in /var/www/html/vendor/magento/framework/Config/Dom.php on line 337

我都是按官方教程来的。
我的版本是2.4.3
大佬看到麻烦指导下

问题关闭,等待新的回答
选为最佳回答
0

xml 需要固定格式。请添加

<?xml version="1.0" ?>
<!--
/**
* @author wolf Team
* @copyright Copyright (c) 2023 email: wolf.tan@zbocloud.com
*/-->
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:noNamespaceSchemaLocation="urn:magento:module:Magento_Store:etc/config.xsd">
   这里是内容
</config>
选为最佳回答
0

图片挂了 没看到具体内容

已回答
0