求助!安装Magento 1.9 带主题的网站出现问题

已解决139 浏览M1交流区libxml

求助!安装Magento 1.9 带主题的网站出现问题

用宝塔+php8.0+mysql8.0安装magento 1.9版本(网上下载的带主题)弹出下面问题:

Deprecated: Function libxml_disable_entity_loader() is deprecated in /www/wwwroot/m1/app/bootstrap.php on line 33

Fatal error: __autoload() is no longer supported, use spl_autoload_register() instead in /www/wwwroot/m1/app/code/core/Mage/Core/functions.php on line 60

针对上面问题,有谷歌翻译的意思如下:

已弃用:函数 libxml_disable_entity_loader() 在第 33 行的 /www/wwwroot/m1/app/bootstrap.php 中已弃用

致命错误:不再支持 __autoload(),请在第 60 行的 /www/wwwroot/m1/app/code/core/Mage/Core/functions.php 中使用 spl_autoload_register() 代替

也简单的google了下,看完后,还是不知怎么来修改。求解决方法,感谢!

问题关闭,等待新的回答
选为最佳回答
0

magento1.9不支持php8.0。 你用php7.0或者7.2应该可以。

发表新评论

老大出手,果然给力,马上就没问题了。万分感谢

1