magento2.3.0需要安装php7.2 报错 ubuntu 16.04

1.83K 浏览M2安装设置

magento2.3.0需要安装php7.2 报错 ubuntu 16.04

按照群主的文档 https://www.kancloud.cn/zouhongzhao/magento2-in-action/729140

执行一下命令的时候报错,请问下怎么处理?

sudo apt-get install -y php7.2 php7.2-fpm php7.2-mcrypt php7.2-curl php7.2-cli php7.2-mysql php7.2-gd php7.2-xsl php7.2-json php7.2-intl php-pear php7.2-dev php7.2-common php7.2-mbstring php7.2-zip php7.2-bcmath php7.2-fileinfo php7.2-soap php7.2-imagick libcurl4 curl -y

0

sudo  apt-get  install  -y  php7.2  php7.2-fpm  php7.2-mcrypt  php7.2-curl  php7.2-cli  php7.2-mysql  php7.2-gd  php7.2-xsl  php7.2-json  php7.2-intl  php-pear  php7.2-dev  php7.2-common  php7.2-mbstring  php7.2-zip  php7.2-bcmath  php7.2-soap  libcurl3  curl  -y

php7.2-fileinfo和php7.2-imagick这2个扩展库都在php7.20common里,所以你不需要单独拿出来安装了。
php7.2-mcrypt在7.2里被废弃了,需要编译安装非常麻烦,不过m2.3.x里也用不着这个库了。2.3里不装mcrypt  应该也不会报错。

0