composer install -v 报错,有朋友遇到这样的情况吗?

1.46K 浏览M2安装设置

composer install -v 报错,有朋友遇到这样的情况吗?

Composer version 1.9.3 2020-02-04 12:58:49

[root@mywebserver www.sohusto.com]# composer install -v

Do not run Composer as root/super user! See https://getcomposer.org/root for det                                                                                                             ails

Loading composer repositories with package information

Installing dependencies (including require-dev) from lock file

Dependency resolution completed in 0.009 seconds

Analyzed 994 packages to resolve dependencies

Analyzed 6626 rules to resolve dependencies

Nothing to install or update

Package zendframework/zend-stdlib is abandoned, you should avoid using it. Use l                                                                                                             aminas/laminas-stdlib instead.

Package zendframework/zend-mime is abandoned, you should avoid using it. Use lam                                                                                                             inas/laminas-mime instead.

Package container-interop/container-interop is abandoned, you should avoid using                                                                                                              it. Use psr/container instead.

Package zendframework/zend-validator is abandoned, you should avoid using it. Us                                                                                                             e laminas/laminas-validator instead.

Package zendframework/zend-loader is abandoned, you should avoid using it. Use l                                                                                                             aminas/laminas-loader instead.

Package zendframework/zend-mail is abandoned, you should avoid using it. Use lam                                                                                                             inas/laminas-mail instead.

Package zendframework/zend-escaper is abandoned, you should avoid using it. Use                                                                                                              laminas/laminas-escaper instead.

Package zendframework/zend-uri is abandoned, you should avoid using it. Use lami                                                                                                             nas/laminas-uri instead.

Package zendframework/zend-diactoros is abandoned, you should avoid using it. Us                                                                                                             e laminas/laminas-diactoros instead.

Package zendframework/zend-http is abandoned, you should avoid using it. Use lam                                                                                                             inas/laminas-http instead.

Package zendframework/zend-psr7bridge is abandoned, you should avoid using it. U                                                                                                             se laminas/laminas-psr7bridge instead.

Package zendframework/zend-hydrator is abandoned, you should avoid using it. Use                                                                                                              laminas/laminas-hydrator instead.

Package zendframework/zend-servicemanager is abandoned, you should avoid using i                                                                                                             t. Use laminas/laminas-servicemanager instead.

Package zendframework/zend-filter is abandoned, you should avoid using it. Use l                                                                                                             aminas/laminas-filter instead.

Package zendframework/zend-inputfilter is abandoned, you should avoid using it.                                                                                                              Use laminas/laminas-inputfilter instead.

Package zendframework/zend-form is abandoned, you should avoid using it. Use lam                                                                                                             inas/laminas-form instead.

Package zendframework/zend-eventmanager is abandoned, you should avoid using it.                                                                                                              Use laminas/laminas-eventmanager instead.

Package zendframework/zend-code is abandoned, you should avoid using it. Use lam                                                                                                             inas/laminas-code instead.

Package zendframework/zend-di is abandoned, you should avoid using it. Use lamin                                                                                                             as/laminas-di instead.

Package zendframework/zend-console is abandoned, you should avoid using it. Use                                                                                                              laminas/laminas-console instead.

Package zendframework/zend-mvc is abandoned, you should avoid using it. Use lami                                                                                                             nas/laminas-mvc instead.

Package zendframework/zend-math is abandoned, you should avoid using it. Use lam                                                                                                             inas/laminas-math instead.

Package zendframework/zend-crypt is abandoned, you should avoid using it. Use la                                                                                                             minas/laminas-crypt instead.

Package zendframework/zend-session is abandoned, you should avoid using it. Use                                                                                                              laminas/laminas-session instead.

Package zendframework/zend-db is abandoned, you should avoid using it. Use lamin                                                                                                             as/laminas-db instead.

Package zendframework/zend-captcha is abandoned, you should avoid using it. Use                                                                                                              laminas/laminas-captcha instead.

Package zendframework/zend-barcode is abandoned, you should avoid using it. Use                                                                                                              laminas/laminas-barcode instead.

Package zendframework/zend-json is abandoned, you should avoid using it. Use lam                                                                                                             inas/laminas-json instead.

Package zendframework/zend-view is abandoned, you should avoid using it. Use lam                                                                                                             inas/laminas-view instead.

Package zendframework/zend-text is abandoned, you should avoid using it. Use lam                                                                                                             inas/laminas-text instead.

Package zendframework/zend-server is abandoned, you should avoid using it. Use l                                                                                                             aminas/laminas-server instead.

Package zendframework/zend-soap is abandoned, you should avoid using it. Use lam                                                                                                             inas/laminas-soap instead.

Package zendframework/zend-serializer is abandoned, you should avoid using it. U                                                                                                             se laminas/laminas-serializer instead.

Package zendframework/zend-config is abandoned, you should avoid using it. Use l                                                                                                             aminas/laminas-config instead.

Package zendframework/zend-modulemanager is abandoned, you should avoid using it                                                                                                             . Use laminas/laminas-modulemanager instead.

Package zendframework/zend-log is abandoned, you should avoid using it. Use lami                                                                                                             nas/laminas-log instead.

Package zendframework/zend-i18n is abandoned, you should avoid using it. Use lam                                                                                                             inas/laminas-i18n instead.

Package zendframework/zend-feed is abandoned, you should avoid using it. Use lam                                                                                                             inas/laminas-feed instead.

Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No                                                                                                              replacement was suggested.

Generating autoload files

Running PHPCodeSniffer Composer Installer

PHP CodeSniffer Config installed_paths set to ../../codeception,../../elasticsea                                                                                                             rch,../../magento/magento-coding-standard,../../phpcompatibility/php-compatibili      

0

Do not run Composer as root/super user! See https://getcomposer.org/root for det ails
不能在root用户下使用composer

0